Degraded service due to internet issues
Incident Report for Ekco NL
Resolved
This incident has been resolved.
Posted Dec 19, 2023 - 14:29 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 19, 2023 - 10:02 CET
Investigating
We are currently investigating this issue.
Posted Dec 19, 2023 - 09:43 CET
This incident affected: Ekco Managed Hosting (Rotterdam - Managed hosting).