Dringend advies aan onze partners om te updaten naar Apache Log4j 2 versie 2.15.0
Incident Report for Ekco Benelux
Resolved
Nagenoeg alle leveranciers hebben een patch of work around gemaakt voor Log4J. We blijven monitoren maar melden voor nu het incident af.
Posted Jan 06, 2022 - 15:30 CET
Monitoring
Log4J houd de gemoederen flink bezig. Er komen nog steeds regelmatig updates en patches uit. Zodra deze beschikbaar zijn, installeren we deze op de Ekco infrastructuur.

Partners wordt aangeraden om de eigen applicaties en updates van de applicaties in de gaten te houden en deze ook van updates te voorzien waar van toepassing.

Een lijst van geaffecteerde producten kan hier worden gevonden:
https://github.com/NCSC-NL/log4shell/blob/main/software/README.md

Indien een leverancier niet op deze lijst staat, hebben wij zelf bij de leverancier gecheckt en juiste maatregelen genomen indien van toepassing. Heeft u vragen, kunt u uiteraard contact opnement met support@ek.co
Posted Dec 21, 2021 - 09:17 CET
Identified
Inmiddels hebben vele leveranciers een patch of work around uitgebracht. Ekco heeft al haar eigen omgevingen gecheckt en patches geinstalleerd waar van toepassing of de eventuele workaround toegepast.

Organisaties worden geadviseerd een afweging te maken of de mogelijkheid tot externe LDAP requests essentieel is voor hun vitale processen. Het aanpassen van deze configuratie mitigeert de kwetsbaarheid en kan worden gezien als goed gebruik.

Een lijst van geaffecteerde producten kan hier worden gevonden:
https://github.com/NCSC-NL/log4shell/blob/main/software/README.md

Indien een leverancier niet op deze lijst staat, hebben wij zelf bij de leverancier gecheckt en juiste maatregelen genomen indien van toepassing. Heeft u vragen, kunt u uiteraard contact opnement met support@ek.co

Daarnaast verwijzen wij u naar deze pagina voor het meest actuele nieuws: https://www.ncsc.nl/actueel/nieuws/2021/december/13/log4j-kwetsbaarheid-bereid-u-voor-op-misbruik
Posted Dec 14, 2021 - 09:49 CET
Investigating
Er is een ernstige kwetsbaarheid verholpen in Apache Log4j, een java log-tool die door veel webapplicaties en diensten wordt gebruikt. De kwetsbaarheid maakt het mogelijk voor een ongeauthenticeerde kwaadwillende op afstand om willekeurige code uit te voeren met de rechten van de webserver. Omdat webservers over het algemeen met beperkte rechten draaien, is de initiële schade beperkt. Echter, doordat de aanvaller willekeurig code op afstand kan injecteren en uitvoeren is de mogelijke gevolgschade niet in te schatten, waardoor het NCSC de impact inschaalt als HIGH/HIGH.

Organisaties worden geadviseerd een afweging te maken of de mogelijkheid tot externe LDAP requests essentieel is voor hun vitale processen. Het aanpassen van deze configuratie mitigeert de kwetsbaarheid en kan worden gezien als goed gebruik.

Er is Proof-of-Concept code gepubliceerd voor deze kwetsbaarheid. Het NCSC verwacht op korte termijn exploitcode en misbruik. https://www.ncsc.nl/actueel/advisory
Posted Dec 11, 2021 - 15:38 CET
This incident affected: Ekco IaaS (IaaS Alkmaar, Iaas Nieuwegein).